EIDViewer on Debian 9 (Stretch).

If you want use your BeID card on your Debian Stretch, you are not enable to install the eidviewer.
The package libproxy1 has no installation candidate, so we must change the dependencies on the package.

1. Download the package

apt-get -d install eid-viewer_4.2.5v4.2.5-0jessie1_amd64.deb

2. Extract the package, here in the current directory,

dpkg-deb -X /home/backfromhell/Downloads/eid-viewer_4.2.5v4.2.5-0jessie1_amd64.deb .

.
3. Extract metadata

dpkg-deb -e /home/backfromhell/Downloads/eid-viewer_4.2.5v4.2.5-0jessie1_amd64.deb ./DEBIAN

.
4. Edit the file DEBIAN/control, find the line Depends and remove the libproxy1.
5. Rebuild the package, go to the parent directory before,

dpkg-deb -b ./debian eid-viewer_4.2.5v4.2.5-0jessie1_BFH__amd64.deb

.
6. Install the new package.

Leave a Reply

Your email address will not be published. Required fields are marked *